tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вмассиве a[100] найти среднее
Вмассиве a[100] найти среднее арифметическое, кратных 5 и кратных 3 элементов массива.
af1045017202
2 08.06.2019 11:10
0
Ответы
Valeriyanka2001
07.07.2020 16:47
var
i,n:integer;
p:real;
a:array[1..100]of integer;
begin
for i:=1 to 100 do
begin
a[i]:=random(50)+1;
write(a[i],' ');
if (a[i] mod 5=0) and (a[i] mod 3=0) then
begin
p:=p+a[i];
n:=n+1;
end;
end;
writeln;
p:=p/n;
writeln('ответ: ',p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
svetlana50036
01.04.2021 16:39
Скласти програму Python, ввійвши змінні a та b. З міста в село Простоквашино виїхав разом з батьками на автомобілі дядя Федір. Коли вони із середньою швидкістю 80...
dimonnovikov0
27.07.2019 05:10
Сформировать одномерный массив из 20 элементов (значения элементов пользователем). увеличить каждый элемент на 1. вывести на экран исходный и итоговый массивы....
Впрвиво199119
05.04.2021 12:56
Напишите программу, которая выводит текст, сформированный из входной строки, повторённой столько раз, сколько составляет разность между первым и последним вводимыми...
kostija73
05.04.2021 12:57
В ветвлении каждая команда...
lolsasafd
13.05.2021 14:01
Сценарий анимации: Акула гонится за рыбкой, если, она догоняет рыбку то программа останавливается (сор информатика )...
АуTист
13.05.2021 14:03
Назовите экологическую проблему изображённую на рисунке...
79521312181
11.10.2021 13:18
3. [2] Дана информация о файле: Какое Подроб Параро НСТРУМЕНТЫ Рисовном Определите размер файла и переведите в соответствующие единицы измерения Кб Байта БИТ •••...
Милята240106
11.10.2021 13:16
Задание 2 ( ). Заполните таблицу пятью примерами искусственных информационных процессов, протекающих в системах. Биологические системы Технические системы Человек...
blackstar19
04.09.2019 11:40
(400*50+5*8000): 10 в квадрате с решением...
785600
04.09.2019 11:40
Сделать словарный диктант как орфограммы ( на каждую орфограмму 5 слов ) буквы а -о в корне -лаг-, -лож-, буквы а-о в корне -раст- , -рос- , буквы е и в корнях с...
Популярные вопросы
Почему хлестаков - самый трудный образ в комедии...
2
Тапсырма. Көнерген сөздер : архаизм және тарихи сөздер болып екіге...
1
Скоротіть дріб: 12 , 56 14 , 70...
2
Какого года началась и закончилась война с Наполеоном...
3
с четвёртым и вторым заданием...
3
Отметьте все правильные утверждения. Маятник - небольшой тяжелый...
1
Вертикальная капиллярная трубка радиусом 10^4м погружена в ртуть....
3
На основі аналізу законів зробіть висновок про ставлення царя...
3
Установи соответствие : A banna102r\моль94r\мольОксид калия(K20)оксид...
1
Сочинение на тему «образ современного человека в поэзии Тютчева...
2
i,n:integer;
p:real;
a:array[1..100]of integer;
begin
for i:=1 to 100 do
begin
a[i]:=random(50)+1;
write(a[i],' ');
if (a[i] mod 5=0) and (a[i] mod 3=0) then
begin
p:=p+a[i];
n:=n+1;
end;
end;
writeln;
p:=p/n;
writeln('ответ: ',p);
end.