tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вдвухмерном массиве а(4,4)найти
Вдвухмерном массиве а(4,4)найти наибольший элемент, лежащий на главной диагонали
Veronichkadyi
2 30.06.2019 08:20
1
Ответы
Lollladka1
23.07.2020 23:16
Var
a: array[1..4,1..4]of integer;
i,j,max: integer;
begin
max:=-MaxInt;
for i := 1 to 4 do
for j:=1 to 4 do
begin
read(a[i,j]);
if (i=j) and (a[i,j]>max) then max:=a[i,j];
end;
writeln('max = ',max);
end.
abs pascal
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
vbackarevap09p0h
16.12.2020 14:54
Скажите как можно самим сделать планшет?...
1i1kuz
16.12.2020 14:54
Какое условие проверяет, лежит ли точка с кординатами (a, b) на прямой,заданной уравнением у = kx + p?if (b= k·a + p)Oif (a = k . b + р)Oif (р = k - a + b)...
Ataka4
16.12.2020 14:53
Вариант № 5 1. Заполните недостающие данные Кбайт : байт = 20480бит 2. Определите информационный размер текстового документа, если он записан с 1024-символьного алфавита,...
valeriafds
16.12.2020 14:52
Дана таблица дат, где хранят температуру за 10 дней. (одномерный массив Dat [ ] ). Программа должна определить сколько дней была температура 15 градусов? Dat [1]:=12;...
настя123настя1
12.08.2019 17:40
3. у маши в ящике лежит 1 красный, 2 чёрных и 4 синих шара. какое наименьшее число шаров нужно взять не глядя, чтобы гарантированно среди них оказался хотя бы 1 чёрный...
MilkaV
12.08.2019 17:40
Написать функцию нахождения номера первого положительного элемента массива язык с...
dndzanton
30.09.2019 06:00
Постройте дерево каталогов по следующим полным именам файлов. c: /рисунки/города/алматы.bmp c: /рисунки/природа/прибой.bmp c: /документы/компьютеры/мышь.gif c: /мои документы/иванов/тест.doc...
Брежний
30.09.2019 06:00
1) напишите программу, которая вводит трехзначное число и разбивает его на цифры. пример: при вводе числа 123 программа должна вывести 1, 2, 3 2) нужно написать такую...
YuliaPyatova
21.05.2019 08:54
Веб программирование современные технологии и возможности - доклад...
sarychevalenka
21.05.2019 08:55
Составить алгоритм для рисователя для построения рисунка из приложенном файле. основа программы: использовать рисовательалгнач-конкоманды для рисователя: в точку (х, у)линия...
Популярные вопросы
Для того щоб пофарбувати куб з ребром 3 см , необхідно 9 кг фарби....
3
Прямоугольный параллелепипед имеет размеры 9 дм, 5 дм, 7 дм. Найдите...
1
подскажите бедной студентке когда степени умножаем там чо происходит...
2
Задание 4Разложи числа в виде суммы разрядных слагаемых14015=321900=909001...
2
Посчитайте столбиком 360:150...
1
Тивонкр из этих букв составить слово...
3
З ким я себе ідентифікую з відомих особистостей...
2
Решить уравнение методом введения новой переменной x/x2-2+6 x2-2/x...
3
Дененің ішкі энергиясының механикалық энергияға түрленетіндігіне мысал...
2
Запишите все значение x красные числу 6 при которых верно неравенство...
3
a: array[1..4,1..4]of integer;
i,j,max: integer;
begin
max:=-MaxInt;
for i := 1 to 4 do
for j:=1 to 4 do
begin
read(a[i,j]);
if (i=j) and (a[i,j]>max) then max:=a[i,j];
end;
writeln('max = ',max);
end.
abs pascal