В результате выполнения программы записанной ниже на экран будет выведено два числа A и B Укажите такое наибольшее число X при вводе которого на экран будет выведено сначала 3 а потом 5. С ОБЪЯВЛЕНИЯМ


В результате выполнения программы записанной ниже на экран будет выведено два числа A и B Укажите та

amishka01 amishka01    2   18.02.2021 14:40    16

Ответы
ShEnNnY ShEnNnY  18.02.2021 14:50

def check(x):

 a=0

 b=0

 while x>0:

   a=a+1

   if b<x%10:

     b=x%10

   x=x//10

 return[a,b]

for i in range(1000000):

 a = check(i)

 if a[0] == 3 and a[1] == 5: print(i)

ответ: 555

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика