В dev c++ Дан массив размера N. Вывести массив на экран в строчку. Найти номер его первого локального максимума.
Локальный максимум – это элемент, который больше любого из своих соседей.
Входные данные размерность массива: 5 0 5 89 10 100
Выходные данные 0 5 89 10 100
Номер элемента массива, первого локального минимума - 3

123Dulya 123Dulya    1   12.06.2020 14:53    2

Ответы
Samatova03 Samatova03  15.10.2020 13:53

#include <iostream>

int main() {

using namespace std;

setlocale(LC_ALL, "Russian");

int N;

cout << "Введите размерность массива: ";

cin >> N;

int* A = new int[N];

for (int i = 0; i < N; i++)

{

 cout << "Заполните [" << i + 1 << "] элемент: ";

 cin >> A[i];

}

cout << endl;

for (int i = 0; i < N; i++)

{

 cout << A[i] << " ";

}

int max_index = 0;

for (int i = 1; i < N; i++)

{

 if (A[i] > A[max_index]) {

  max_index = i;

 }

}

cout << "\nНомер локального максимума: " << max_index + 1;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика