tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Требуется написать программу
Требуется написать программу для перевода целых чисел из восьмеричной системы счисления в десятичную.
алинекмалинек
2 12.07.2019 19:10
0
Ответы
Kuprums
03.10.2020 01:59
Var o,d,k,l: integer;
begin
read(o);
d := 0;
k := 1;
l := 1;
while l <= o do
begin
d := d + k*(o div l mod 10);
l := l * 10;
k := k * 8
end;
writeln(d)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
dashab1212200
13.06.2019 12:40
1.вождь племени мульти поручил своему министру разработать двоичный код и перевести в него важную информацию. какой разрядности потребуется двоичный код, если алфавит,...
Blackstone111
13.06.2019 12:40
Вычислите объем видеопамяти, необходимый для изображения глубиной цвета 16 битов и разрешающей экрана 1024х768...
ooz
13.06.2019 12:40
Кнопка , являющаяся одним из главных элементов операционной системой...
elviraborysenko
13.06.2019 12:40
Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа....
sna2003
13.06.2019 12:40
Составить кроссворд используя название устройств компьютер...
Sasjaghf
29.10.2020 12:50
Автомат обрабатывает натуральное число N по следующему алгоритму: 1. Строится двоичная запись числа N. 2. Удаляется первая слева единица и все следующие непосредственно...
masky80984Женя
29.10.2020 12:49
Какой разрядность потребуется двоичный код если алфавит содержит 130 синмолов...
дада211
29.10.2020 12:49
Кто понимает сишарп с программированием!...
Difren
29.10.2020 12:49
Всем привет Конфеты находятся в одной из 10 коробок. Определить количество информации.2. Тетрадь лежит на одной из двух полок - верхней или нижней. Сколько бит несет...
Макс332211
29.10.2020 12:49
Расположи слова так, чтобы получилось определение команды ВСТАВИть. ВСТАВИТЬ - этоили команда, помещает в указанное место.скопированный текст которая вырезанныйеНазадВ...
Популярные вопросы
с таблицей по географии 7 класс.Евразия. Умеренный,субэкваториальный,тропический...
1
Өсімдіктер мен жануарлардың экожүйедегі маңызы? ...
2
❗❗Над чем заставляет задуматься рассказ «Мы приговариваем тебя...
2
Написать сочинение на 1 листочек про любую военную песню...
2
Послушай чтение одноклассников и обсуди, можно ли назвать прочитанное...
2
Выполните синтаксический разбор предложений: И хотя Баласагун...
2
Зачем Баба- яга прикладывает ухо к земле ?Почему недоволен рыбак?...
2
Написати лист дідусеві на фронт...
3
Исторические достопримечательности Казахстана доклад...
2
Оформить таблицу Русские путешественники и первопроходцы ....
1
begin
read(o);
d := 0;
k := 1;
l := 1;
while l <= o do
begin
d := d + k*(o div l mod 10);
l := l * 10;
k := k * 8
end;
writeln(d)
end.