Требовалось составить программу для вычисления Y по формуле: 2Х+1, при всех значениях Х более 10, или по формуле: АХ-В, для всех остальных значений Х. Программист написал четыре варианта программы, но каждый раз ничего не получилось исправьте все ошибки (они могут быть как синтаксическими (т. е. не позволяют запустить программу), так и логическими (программа работает, но неправильно)). Это можно сделать как с среды программирования PascalABC, так и самостоятельно. Файл должен содержать Ваши исправления программы в следующем виде:
Неправильная строка исправить на: Правильная строка
Количество таких строк должно соответствовать количеству найденных ошибок. Изменять структуру программы, удалять или добавлять строки нельзя!
3 вариант
program vetvlenie3;
var a, b, x,y: real;
begin
readln (Y);
if x>0 then
y:=2x+1
else
y:=ax-b;
writeln (Y);
end.