Тема: рекуррентные соотношения. написать программу для вывода последовательности условие: b1=5; bn=(-1)^n * bn-1 -8 минус 1 в степени n, умножить на b n-1 (n-1 -> подстрочный текст) - 8 начинаю писать программу, а в степень без
понятия как возвести program posledovatelnost; uses crt; var i,n: integer; b1,bn: real; begin clrscr; writeln ('введите n'); readln (n); b1: =5; writeln ('1 элемент = ', b1); for i: =2 to n do begin bn: = writeln (i, 'элемент = ', bn); b1: =bn; end; readln end. что написать, чтобы считать правильно bn,
нужно чтобы работало в tp, поэтому power,pow и exp бесполезны.

alicaraut alicaraut    3   07.03.2019 18:30    3

Ответы
Arisha7777 Arisha7777  08.05.2020 06:56

var

b1,b2,i,n,p:integer;

begin

write('введите n');
readln (n);
b1:=5;
writeln ('1 элемент = ', b1);

p:=-1;

for i:=2 to n do

begin

p:=p*(-1);

b2:=p*b1-8;

writeln (i,' элемент = ', b2);

b1:=b2;

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика