tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Сумму четных элементов
Сумму четных элементов одномерного массива до 1 встречного нулевого элемента
tata201279
1 23.05.2019 03:20
1
Ответы
SoniaSS09
18.06.2020 18:49
Var
a,i,n:integer;
b:array [1..50] of integer;
begin
readln(n);
for i:= 1 to n do
readln(b[i]);
i:=1;
a:=0;
while (b[i]<>0) and (i<=n) do
begin
if b[i] mod 2 =0 then a:=a+b[i];
inc(i);
end;
writeln('Сумма четных элементов = ',a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ZHENYAKIM2008
23.06.2019 14:50
1.md5 суммы нужны для того, * 1. упорядочить расположение файлов на компьютере 2.уменьшить размер файлов на вашем компьютере. 3.проверить целостность пересылаемых...
Macsum204
24.04.2021 11:12
1 вопрос:Який опис змінної типу список і надання їй значення послідовності з 5 цілих чисел є правильним? Позначте одну правильну відповідь. ответить на все вопросы....
ашпшплщ
24.04.2021 11:08
Построение таблиц истинности 1)F=(CvB) v(A¬vC)...
Margaritka1307
24.04.2021 11:08
Задано множество о студентах (фамилия, имя, отчество, группа и оценка). Составьте программу, которая генерирует и выводит на экран 2-ое множество из студентов,...
Ната911
05.09.2019 22:30
Примеры: объективной информации,достоверной информации,полноты информации,точности информации,актуальности информации и ценности информации....
Yaroslav1RUS
05.09.2019 22:30
Комп’ютер шкільної локальної мережі має ip-адресу 192.168. 0. 255; запишіть числом максимально можливу кількість комп’ютерів у цій локальній мережі....
анна2248
27.05.2019 00:30
Вфотоаппарате кукушка установлена 4-мегапиксельная матрица. в настройках фотоаппарата выбраны: количество цветов 2^16 (степень), коэффициент сжатия 0,5. сколько...
FreddikSmall
27.05.2019 00:30
Даны два предложения разделённые точкой . вывести первое предложение...
fragerin
27.05.2019 00:30
Сообщение , записанное 128-символами алфавита , содержит 30 символов. каков объем информации оно несет...
madishalabaev
27.05.2019 00:30
Алина набрала на мобильном телефоне sms сообщение из пяти букв и использовала кнопки 6 5 2 5 6 данное слово означает технологическое устройство и наченается с согласной...
Популярные вопросы
Антоним к слову late,funny,difficuit,expensive,boring...
3
Разбор слова как часть речи: расстелила, смешно...
1
Не унижайте себя копированием самих себя или чужих умных мыслей!...
1
Сочинение на тему: закон суров, но это закон....
2
Фосфорная кислота+хлорид кальция основание алюминия+азотная...
3
Задали похожий рассказ по типу евгения шварца два брата . заранее...
2
Дать характеристику шерлока холмса за планом, 1.портрет героя....
1
Напиши листа до свого друга спочатку розкажи про себе.а потим...
2
Расшифруйте числовой ребус сел умножить сел=подсел...
1
Іть написати 5-6 речень про весну з однорідними означеннями....
1
a,i,n:integer;
b:array [1..50] of integer;
begin
readln(n);
for i:= 1 to n do
readln(b[i]);
i:=1;
a:=0;
while (b[i]<>0) and (i<=n) do
begin
if b[i] mod 2 =0 then a:=a+b[i];
inc(i);
end;
writeln('Сумма четных элементов = ',a);
end.