Спрограммой, ! нужно написать программу, которая по вводу с клавиатуры последовательности целых чисел (признак окончания ввода- ввод числа 0) подсчитывает среднее арифметическое нечетных чисел и чисел, кратных 5.

arrrrrrrrr1 arrrrrrrrr1    1   01.06.2019 15:00    0

Ответы
лол1634 лол1634  02.07.2020 18:03
Var
   A,i:integer;
   B:real;
Begin
repeat
Writeln('Введи число.');
ReadLn(A);
if (A mod 10 =0) then
 Begin
  i:=i+1;
  B:=A+B;
 End;
until (A=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 равно: ',B/(i-1));
ReadLn
End.
ПОКАЗАТЬ ОТВЕТЫ
akakkakksksak akakkakksksak  02.07.2020 18:03
Var x,i:integer;
   y:real;
Begin
writeln('Признак окончания ввода - ввод числа 0');
repeat
Writeln('Введите число');
ReadLn(x);
if (x mod 2 >0) and (x mod 5 = 0) then 
Begin  i:=i+1; 
 y:=x+y; 
End;
until (x=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 = ',y/i);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика