Составьте программу, запрашивающую у пользователя k целых чисел и вычисляющую произведение положительных. пример работы: окно вывода сколько чисел обработать? 5 введите число 2 введите число введите число введите число введите число произведение положительных чисел из 5 составляет 24 а то я уже сижу рыдать начинаю (через паскаль надо

yaroslavus yaroslavus    3   25.09.2019 12:10    0

Ответы
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Сколько чисел обработать?');
  var s:=1;
  loop n do begin
    var k:=ReadInteger('Введите число');
    if k>0 then s*=k
    end;
  Writeln('Произведение положительных чисел из ',n,' составляет ',s)
end.

Пример
Сколько чисел обработать? 5
Введите число 7
Введите число -4
Введите число 0
Введите число 9
Введите число -2
Произведение положительных чисел из 5 составляет 63
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика