Составьте программу, запрашивающую 4-х значное число. и выходящую на экран сообщение : "тысяч_, сотен_, десятков_, единиц_".применяя функции деления (div и mod) 2.составьте программу делящую переменную а=100 на 3. деление прекратить когда остаток а будет меньше 3. подсчитать количество вариантов деления и вынести значение на экран.

ксюня264 ксюня264    2   06.06.2019 13:50    1

Ответы
artemonimus artemonimus  01.10.2020 20:41
1.
var s,a,b,c,d:integer;
begin
readln(s);
a:=s div 1000;
b:=s div 100 mod 10;
c:=s div 10 mod 10;
d:=s mod 10;
writeln('Тысяч ',a,' Сотен ',b,' Десятков ',c,' Единиц ',d);
end.

2.
var k,a:integer;
begin
a:=100;
while a>=3 do begin
a:=a div 3;
k:=k+1;
end;
writeln(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика