Составьте программу замены в слове,введенном с клавиатуры,всех букв"и" на"а"и"а"на"о".сосчитать количество замен.отладка программы для слова"накидка"

IvanPAW2145778 IvanPAW2145778    1   20.05.2019 12:20    4

Ответы
Danil02020202 Danil02020202  13.06.2020 22:09

Program Stroka;

Uses Crt;

var a:string;

 

      c1,c2, i,k:integer; 

begin

    clrscr;

    write('Введите строку: ');

    readln(a);

    k:=length(a);

c1:=0;c2:=0;

 

// Первый проход меняем "и" на  "a"  

   for i:=1 to k do   if(a[i]='и') or (a[i]='И') then

        begin  

               a[i]:='а';

               c1:=c1+1;

 

         end;

    // Второй проход меняем "а" на  "о"    

 

   for i:=1 to k do   if(a[i]='а') or (a[i]='А') then

            begin

 

                 a[i]:='о';     

                  c2:=c2+1;  

 

             end;

writeln;

 

 

 

 writeln('Строка после всех замен:',a);

 

 writeln('Замен и на а:',c1);

  writeln('Замен a на о:',c2); 

    readkey;

 

end. 

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика