Составьте программу замены нулевых элементов таблицы единицами контрольный пример n=5 данные : (0,5,0,60,0) результат : (1,5,1,60,1)

Вовка753 Вовка753    3   28.07.2019 04:20    3

Ответы
NataNati NataNati  03.10.2020 15:10
Язык Pascal, работа на массиве. с заполнением с клавиатуры. Ты заполняешь 5 элементов ( через enter ), а он тебе выводит тоже самое, только с однерками вместо нулей.

Var x: array[1..5] of integer;
Var i,h:integer;
Begin
for i:= 1 to 5 do
Begin;
Readln(h);
if (h=0) then x[i]:=1 else x[i] = h;
end;
for i:=1 to 5 do
Begin;
Writeln('Элемент номер ',i,' массива: ',x[i]);
end;
readln(x);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика