Составьте программу, выясняющую какая из букв п или в встречается раньше.

nastyagorcha nastyagorcha    1   30.06.2019 15:40    0

Ответы
khaub456 khaub456  24.07.2020 08:33
Var
  str:string;
  i:integer;

begin
  readln(str);
  for i:=1 to Length(str) do
    if ( str[i] = 'П' ) OR ( str[i] = 'В' ) then
      break;
  writeln(str[i]);
end.
ПОКАЗАТЬ ОТВЕТЫ
alladzyurich alladzyurich  24.07.2020 08:33
В Паскале есть стандартная функция Pos, которая возвращает начальную позицию вхождения подстроки в строку или 0, если такое вхождение не обнаружено. С её данная задача решается очень просто.

var
  s:string;
  ip,iv:integer;
begin
  Write('Введите строку: '); Readln(s);
  ip:=Pos('П',s); iv:=Pos('В',s);
  if ip*iv=0 then Writeln('П или В или обе не найдены в тексте')
  else
    if ip<iv then Writeln('П встретилось раньше В')
    else Writeln('В встретилось раньше П')
end.

Тестовое решение:
Введите строку: НА ЛУГУ ПАСЕТСЯ КОРОВА
П встретилось раньше В
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика