Составьте программу вычисления суммы факториалов всех чётных чисел от m до n.

alexandur96 alexandur96    1   14.06.2019 18:16    7

Ответы
кристина0052368 кристина0052368  02.10.2020 01:59

var

 m, n, i: integer;  

 sum: real;

function fact(x: integer): real;

begin

 if x = 0 then fact := 1  

 else fact := fact(x - 1) * x;  

end;

begin

 writeln('Введите границы m и n соответственно : ');

 readln(m, n);  

 sum := 0;  

 for i := m to n do if not odd(i) then  

 sum := sum + fact(i);

 writeln('Сумма факториалов четных чисел последовательности = ', sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика