Составьте программу вычисления произведения простых делителей натурального числа n.

BOYECH BOYECH    3   27.05.2019 17:50    2

Ответы
9fhneh 9fhneh  01.10.2020 12:54
var
x,i,n: integer;
begin
x:=1;
write('Введите натуральное число: ');
read(n);
write('Простые делители числа ',n,': ');
for i:= 1 to n do
 if n mod i = 0 then
  begin
  write(i:4);
  x:=x*i;
  end;
writeln;
writeln('Их произведение: ',x);
end. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика