Составьте программу(в паскале), которая заполнит массив a[1..16]случайными целыми числами в диапазоне от -20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа,кратные 5, а остальные уменьшает на 10. затем выводит на экран преобразованный массив.

OtlichnitcaAnna OtlichnitcaAnna    1   02.10.2019 07:00    0

Ответы
Ксеня228 Ксеня228  09.10.2020 11:13

const n=16;

var a:array [1..n] of integer;

i:integer;

begin

for i:=1 to n do a[i]:=random(41)-20;

writeln('Исходный массив: ');

for i:=1 to n do write(a[i]:5);

writeln;

for i:=1 to n do

if a[i] mod 5 = 0 then a[i]:=a[i]*2 else a[i]:=a[i]-10;

writeln('Преобразованный массив: ');

for i:=1 to n do write(a[i]:5)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика