Составьте программу в паскале для поиска: a)суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов

ivankal ivankal    3   17.09.2019 15:00    0

Ответы
Nastyxas Nastyxas  07.10.2020 22:05
А) uses crt;
const n=10;
var a:array[1..n] of integer;   
i,sum:integer;
begin
for i:=1 to n do   
begin         
a[i]:=random(100)-50;         
write(a[i]:4);         
if a[i]>0 then sum:=sum+a[i];   
end;
writeln;
writeln('Сумма положительных элементов = ',sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика