Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в строчку через промежутки по порядку его цифру.

Eennoottt Eennoottt    2   26.05.2019 20:08    0

Ответы
tyomking tyomking  23.06.2020 10:59

Один из примеров реализации на JS, Pascal:


Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в стро
Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в стро
ПОКАЗАТЬ ОТВЕТЫ
Нннннннн11 Нннннннн11  23.06.2020 10:59

program raf105;

var

 a:array[1..6] of integer;

 n,i: integer;

begin

 write('Введите шестизначное число: ');

 readln(n);

 a[1]:= n div 100000;

 a[2]:= (n div 10000) mod 10;

 a[3]:= (n div 1000) mod 10;

 a[4]:= (n div 100) mod 10;

 a[5]:= (n div 10) mod 10;

 a[6]:= n mod 10;

 write('Вывод: ');

 for i:= 1 to 6 do

   write(a[i],' ');

 end.

PascalABC 3.4.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика