Составьте программу получения в порядке убывания всех делителей данного числа n. число n вводится с клавиатуры. .

skyline12345 skyline12345    1   30.08.2019 04:30    2

Ответы
sofapravdina sofapravdina  06.10.2020 04:23
Var n,i:integer;
begin
write('n = ');
readln(n);
writeln('Делители числа ',n,':');
for i:=n div 2 downto 1 do
 if n mod i=0 then write(i,' ');
end.

Пример:
n = 24
Делители числа 24:
12 8 6 4 3 2 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика