Составьте программу подсчета общего количества слогов "не", "не" во введенной с клавиатуры строке s. пример ввода: не стыдно не знать - стыдно не учиться.

Aliiev19 Aliiev19    3   30.09.2019 13:40    4

Ответы
Fenef Fenef  09.10.2020 05:34
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018Внимание! Если программа не работает, обновите версию!

begin

 ReadlnString.MatchValues('[Нн]е').Count.Println

end.

ПОКАЗАТЬ ОТВЕТЫ
НикаКлубника11 НикаКлубника11  09.10.2020 05:34

var s:string;

i,k:integer;

begin

write ('Введите строку: ');

readln (s);

for i:=1 to length(s)-1 do

if ((s[i]='н') or (s[i] = 'Н')) and ((s[i+1] = 'е') or (s[i+1] = 'Е')) then k:=k+1;

write ('Количество слогов не равно: ',k)

end.


Составьте программу подсчета общего количества слогов не, не во введенной с клавиатуры строке s.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика