Составьте программу, определяющую принадлежность точки а(х, у) окружности с центром 0(0; 0) и радиусом r. в паскалеabc.

гуудик гуудик    2   09.06.2019 07:00    0

Ответы
yeghiazaryanhap01lbi yeghiazaryanhap01lbi  01.10.2020 22:53
Var x,y,r:real;
begin
writeln('Введите радиус окружности');
readln(r);
writeln('Введите координаты точки А');
readln(x,y);
if sqr(x)+sqr(y)=sqr(r) then writeln('Принадлежит')
else writeln('Не принадлежит');
end.
ПОКАЗАТЬ ОТВЕТЫ
satanbeat satanbeat  01.10.2020 22:53
Var x,y,r:real;
begin
readln(r);
readln(x,y);
    if sqr(x)+sqr(y)<=sqr(r) then
        writeln('принадлежит')else writeln('не принадлежит');
end.
в предыдущем решении точка лежит только на границе окружности
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика