Составьте программу, определяющую, лежит ли точка с указанными координатами x, y на окружности радиуса r с центром в начале координат. program frankenstein; var x,y,r: integer; begin write('введите координату x: '); readln(x); write('введите координату y: '); readln(y); write('введите длину радиуса r: '); readln(r); if (sqr(x)+sqr(y))=r then writeln('точка лежит на окружности! ') else writeln('точка не лежит на окружности! '); end. почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! где я ошибся?

mar244144 mar244144    2   28.05.2019 02:50    12

Ответы
HLNLZ HLNLZ  25.06.2020 13:09
R^2
Var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=sqr(r)  then 
writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы