tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу определения
Составьте программу определения наименьшего общего делителя двух натуральных чисел
lizon392
3 28.05.2019 21:20
0
Ответы
Sofia1863
26.06.2020 16:20
Program a1;
var m,n,p:longint;
begin
readln(m,n);
p:= m*n;
while m <> n do
begin
if m>n then begin
m:=m-n
end
else
begin
n:=n-m;
end
end;
writeln(p div m);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
klychkovs66
20.05.2019 08:30
Составьте алгоритм значений трех переменных по возрастанию, т.е. при любых исходных значениях а, в, с отсортируйте так, чтобы стало а...
vitalyrtss
18.07.2019 14:50
Вкаких системах счисления может быть записано число 1500?...
hromovaysoydwfz
13.05.2021 09:08
Акой режим обновления оглавления нужно выбрать, если в текстовый документ после создания оглавления добавляются изображения, таблицы илитекстовая информация?Обновление оглавленияВыберите...
Anutazaitseva2002
13.05.2021 09:06
У Миколи є 5 гривень. Визначити чи вистачить йому цих грошей для покупки трьох олівців, які коштують по п гривень. Вивести повідомлення «вистачить» або «не вистачить»....
TheGreatHaterMisha
10.08.2020 14:40
Какое из указанных имён файлов удовлетворяет маске (С РЕШЕНИЕМ!)...
daria003ss2
10.08.2020 14:56
Користувач вводить число якщо він вводить щось крім числа то заміняєш його на рандомні числа від 1 до 20...
elenakovaleskau
10.08.2020 14:58
Решите уравнение 62_n=80_10...
mashoshinaliza1
23.06.2019 12:10
типы операндов не соответствуют операции . не могу найти ошибку, подскажите строчка, в которой ошибка: if (a mod 2 = 0) then a: =a/2;...
varta
27.05.2020 10:42
7 класс информатика8. назовите виды компьютера...
Быковских
22.12.2020 07:45
Назовите структурные компоненты клетки, которые имеются и у прокариот, и у эукариот: А) лизосома Б) эндоплазматическая сеть В) рибосомы Г) аппарат Гольджи Д) митохондрии...
Популярные вопросы
Образуйте от количестенных числительных порядковые. 27,14,590 200,2500,...
3
Катер шёл 0,6ч против течения реки,скорость течения которой 2,5км/ч и...
3
Уравнение реакции разложения карбоната кальция сасо3 (к) = сао (к) +...
3
Выписать из предложения как вдруг от сильного движения ермолая, здорового...
1
Что означают эти слова? патриций,плебей,народный трибун,консул ,ликтор,форум,марсово...
2
При каких значениях с окружностью х^2 + y^2=18 и прямая x-y=c не пересекаются...
1
Монолог 20 предложений по теме времяпровождение в наше время...
1
Число которое делят на данное число...
2
Составить парадигму слова озеро, нужно! (...
3
Скласти молекулярні, повні і і йонні рівняння реакцій, які відображають...
1
var m,n,p:longint;
begin
readln(m,n);
p:= m*n;
while m <> n do
begin
if m>n then begin
m:=m-n
end
else
begin
n:=n-m;
end
end;
writeln(p div m);
end.