Составьте программу нахождения наибольшего общего делителя трех чисел,используя следующую формулу: нод(а,в,с)=нод(нод(а,в),с).

Dan363 Dan363    3   09.03.2019 16:10    25

Ответы
Soniasizova Soniasizova  24.05.2020 11:24

#include <cstdlib>
#include <iostream>

 

using namespace std;

 

int NOD( int a, int b)
{
   int c=1;

   int d;

   if(a>b)

    d=b;

   else

    d=a;
   for(int j=1;j<=d;j++)
   {
    if(a%j==0 && b%j==0)
    c=j;       
   }
   return c;     
}

 

int main()

{

 int A,B,C;

 cout<<"Введите А"<<endl;

 cin>>A;

 cout<<"Введите В"<<endl;

 cin>>B;

 cout<<"Введите С"<<endl;

 cin>>C;

 cout<<"НОД("<<A<<","<<B<<","<<C<<")="<<NOD(NOD(A,B),C)<<endl;

 system("PAUSE");

 return 0;

}

 

 

 

 

(Код написан на С++.)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика