Составьте программу нахождения наибольшего общего делителя для двух чисел. (воспользоваться алгоритмом евклида). алгоритм евклида поиска наибольшего общего делителя двух чисел: вычитай из большего меньшее, пока числа не станут равны. полученное значение и будет искомым.

nastyakholod92 nastyakholod92    2   27.05.2019 15:10    0

Ответы
досметова досметова  24.06.2020 16:25
Var  a, b: word;
function NOD(x, y: integer):integer;
begin 
repeat    
 if abs(x) > abs(y) then      
 x := x mod y    
else    
  y := y mod x;  
until (x = 0) or (y = 0); 
  NOD := abs(x + y);
 end;
begin 
 write('a=');read(a);  
 write('b=');readln(b); 
writeln('NOD(a,b)=', NOD(a, b)); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика