Составьте программу на языке паскаль: поменять местами первую и последнюю цифры четырёхзначного числа. !

zenkov2000cemen zenkov2000cemen    3   08.06.2019 00:00    0

Ответы
ayla678 ayla678  07.07.2020 12:52
Var a,a1,a2,a3,a4;
begin
read (a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
a:=a4*1000+a2*100+a3*10+a1;
write (a);
end.
ПОКАЗАТЬ ОТВЕТЫ
byrzakovskaya byrzakovskaya  07.07.2020 12:52
Uses Crt;
var   x : Integer; 
Zn:Char; 
strNum:string;  
begin  
ClrScr; 
Write('Введите четырех значное число: '); 
ReadLn(x);   
Str(X,strNum); 
Zn:=strNum[1]; 
strNum[1]:=strNum[Length(strNum)]; 
strNum[Length(strNum)]:=Zn; 
x:=StrToInt(StrNum); 
writeln(strNum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика