Составьте программу на языке паскаль и так, вопрос по паскалю, сие не найти в интернете (ну по крайней мере мне) вопрос: как оператор case заключить в case. самое главное чтобы можно было сделать программу которая могла работать так: »выберите раздел »1- »2- »3- 1 »вы выбрали »выберите действие »1-узнать скорость »2-узнать путь 1 »введите время пути в часах и так далее там. если нужен пример кода то вот, но он не рабочий: var v,g,a,f: char; time: real; lenght: real; speed: real; begin writeln('выберите раздел: '); writeln('1-'); writeln('2-'); writeln('3-'); writeln('ваш выбор: '); readln(v); case v of '1' begin writeln('выберите действие'); writeln('1-узнать скорость'); writeln('2-узнать путь'); write('ваш выбор: '); readln(f); case f of '1': begin writeln('введите время пути в часах'); readln(time); writeln('введите длину пути в киллометрах '); readln(lenght); speed: =lenght/time; writeln('скорость=', speed: 5: 1,'км/ч') end; '2': begin writeln('введите скорость движения в км/ч'); readln(speed); writeln('введите время пути в часах'); readln(time); lenght: =speed*time; writeln('путь=', lenght: 5: 1,'км'); end else writeln('ощибка, такого пункта нет! '); end; end; end.

00Alcatraz00 00Alcatraz00    2   14.09.2019 20:30    3

Ответы
Like2942 Like2942  07.10.2020 15:10
1) тут не поставил PROGRAM имя; var
2) case v of
"1" тут не поставил доветочие
3) else writeln(); тут не поставил end; один штуку, который закончит начала case f of
но ты краб его поставил до else я понял, а надо после, потому что else принадлежит не case v, а case f.

и всо он заработал вот код
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика