Составьте программу на паскале для пяти чисел по убыванию и нахождение их суммы

MariHarutyunyan MariHarutyunyan    3   23.09.2019 14:30    1

Ответы
Наталья999111 Наталья999111  08.10.2020 12:32
Var
  A: array [1 .. 5] of real;
  i, j: byte;
  sum, tmp: real;

begin
  sum := 0;

  { Заполнение массива }
  for i := 1 to 5 do
  begin
    write('A[', i, '] = ');
    readln(A[i]);
    sum := sum + A[i]; // подсчет суммы
  end;
  writeln(#13 + 'Сумма элементов = ', sum);

  { Сортировка по убыванию }
  for i := 1 to 4 do
    for j := i + 1 to 5 do
      if A[i] < A[j] then
      begin
        tmp := A[i];
        A[i] := A[j];
        A[j] := tmp;
      end;

  { Вывод }
  writeln('Отсортированный массив: ');
  for i := 1 to 5 do
    write(' ', A[i]);

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика