Составьте программу, которая заполняет массив случайными целыми числами в диапазоне от 1 до 10 и выводит на экран cумму элементов с четными значениями и количество нечетных значений.

kadaran kadaran    3   16.08.2019 11:20    1

Ответы
shkuratov89525510021 shkuratov89525510021  04.10.2020 22:47
Const n=14;
var c:array[1..n] of integer;
s,k,i:integer;
begin
k:=0;
s:=0;
for i:=1 to n do begin
c[i]:=random(10)+1;
write(c[i]:4);
end;
writeln;
for i:=1 to n do
if c[i] mod 2=0 then s:=s+c[i]
else k:=k+1;
writeln('сумма четных элементов = ',s);
writeln('кол-во нечетных чисел= ', k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика