Составьте программу, которая преобразует расстояния до некоторых ближайших к земле звёзд из световых лет в парсеки(1 пк = 3, 26 св. лет). проксима центавра 4,24 св. лет альфа центавра 4,37 св. лет сириус 8,58 св. лет эпсилон эридана 10,52 св. лет процион 11,4 св. лет эпсилон индейца 11,82 св. лет тау кита 11,89 св. лет тема : преобразование массива, информатика.
#include <iostream>
int main() {
for(;;) {
double sg, pk_1 = 3.26;
std::cin >> sg; // Вводишь расстояние до звезды
std::cout << sg / pk_1 << std::endl;
if (sg == 0) break; // если вводишь 0, программа завершается
}
return 0;
}
// программа выводит на экран значение расстояния до звезды в парсеках