tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу
Составьте программу ,которая позволяет удалить символы t из строки s.строка s и символ t,который надо удалить,вводятся с клавиатуры
Tiktak222
2 26.05.2019 22:50
4
Ответы
banni11
23.06.2020 15:27
Тогда вот, все по букве задания
var
s : string;
t : char;
i : integer;
begin
readln (s);
read (t);
i := 1;
while (i <= length (s)) do
begin
if s[i] = t then delete (s, i, 1)
else i := i + 1;
end;
writeln (s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
алина3539
27.08.2019 07:20
Назовем простое число суперпростым, если в его десятичной записи есть только цифры, являющиеся простыми числами, например, числа 2, 3, 5, 7, 23 — суперпростые, а 13 —...
ivandawidov
27.08.2019 07:20
Записали выражение: 104−(103)+102−(101)+…+2−(1) (знаки плюс и минус чередуются). можно поменять местами любые два числа (не трогая знаки), а затем вычислить значение...
rockmus
11.09.2019 15:40
Правильно записать. у меня проблемы с паскалем( с клавиатуры вводятся два целых числа. сколько раз в их произведении встречается цифра 0...
АрзуНаз
11.09.2019 15:40
Свойство алгоритма заключающиеся в том что каждое действие и алгоритм в целом должны иметь возможность завершения называется...
Danil0220
11.09.2019 15:40
Втакой программе, пишет что = не применимо к var n, a, k: integer; begin readln(n, a); if (n+a) mod 2=0 or (n+a) mod 2=1 then writeln(k - (k div n) * n ) end....
DanilДюжик
20.11.2021 07:04
Задание 6 сделайте очень сильно нужно ( с объяснением ) решите сегодня ( и что бы учитель не знал что я решил через интернет ФАЙЛ ПРИКРЕПЛЕН ПОЖ...
DathVayolet
20.11.2021 07:01
Алгоритм копіювання файлів...
poolliinnaa
04.03.2021 11:00
Нарис у публіцистичному стилі даю 10 білів скоріше ( про кого хочете)...
Макс777333
04.03.2021 11:00
По типу сообщения ,подробно. 1.Как появилась испанская фаланга? 1933-362.Каким образом испанская фаланга пришла к власти?3.Как появился нацистский режим...
ksyuksu1234
04.03.2021 11:00
1. What kind of organ is the brain? 2. What unites the brain and the muscles?3. Is the brain sensitive to pain? Why? Why not?4. When does the brain rest?...
Популярные вопросы
Прочитайте начало рассказа. Почему автор заостряет внимание на деталях...
2
Сталевий стрижень завдовжки 20 см і масою 100 г лежить перпендикулярно...
2
Use had or shall/will have . By the end of last month they ...not...
3
Даны следующие шаги построениятреугольника:1. провести прямую.2. Провести...
1
Вычислите рН ацетатного буферного раствора, если концентрация кислоты...
2
Розв, яжіть будьласка нерівність а) (-1,6+4,4):0,7+0,85:(-1,7)...
1
Вот иногда делишь числа, и получается странная десятичная дробь по...
1
Найбільші запаси золота та алмазів в Азії характерні для...
1
15,6x+27,4−9,2x−x решите плез...
3
Докажите равенство прямоугольных треугольников по катету и высоте,опущенной...
1
var
s : string;
t : char;
i : integer;
begin
readln (s);
read (t);
i := 1;
while (i <= length (s)) do
begin
if s[i] = t then delete (s, i, 1)
else i := i + 1;
end;
writeln (s);
end.