Составьте программу, которая по введенному вами K - числу грибов печатает фразу <Мы нашли в лесу K грибов>, причем согласовывает окончание слова <гриб> с числом K. Количество грибов может быть любым целым числом: 1, 3, 34, 127 и т.д. Окончание фразы определяется значением последней цифры.
if k<0 then
writeln('Не может такого быть')
else
begin
write('Мы нашли в лесу ',k,' гриб');
if (k mod 100 in [5..19]) then
writeln('ов')
else if (k mod 10 in [2..4]) then
writeln('а')
else if (k mod 10=1) then
writeln
else
writeln('ов');
end;
end.
k = int(input ('Сколько вы нашли грибов? : '))
if k == 1 :
print('Я нашел 1 гриб')
if k == 2 :
print('Я нашел 2 гриба')
if k == 3 :
print('Я нашел 3 гриба')
if k == 4 :
print('Я нашел 4 гриба')
if k >= 5 :
print ('Я нашел ' + str(k) + ' грибов!')
Если вы хотите отблагодарить меня, то поставьте этому ответу "Лучший".