tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу, которая
Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от -40 до 40 и увеличивает в 2 раза числа , кратные 5, а остальные уменьшает на 2.
mavlud111
1 08.08.2019 17:50
0
Ответы
joker2284
04.10.2020 05:33
Var
a: array[1..100] of integer;
i, n: integer;
begin
{ввод массива}
n := 15;
writeln('Данные массива:');
for i := 1 to n do
begin
a[i] := random(40 + 40) - 40;
write(a[i], ' ');
end;
writeln();
{изменение элементов}
for i := 1 to n do
begin
if a[i] mod 5 = 0 then
a[i] := 2 * a[i]
else a[i] := a[i] - 2;
write(a[i], ' ');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
katea001
20.05.2019 04:50
Сканируется цветное изображение размером 2x3 дюйма. разрешающая сканера -600x600 dpi, глубина цвета - 8 битов. какой информационный объём будет иметь полученный графический файл?...
vvbybrjnbr
08.02.2022 05:37
Hey, I m playing in LogoTest app, the hottest game right now! Download now through the link and get 5,000 Coins. https://logotestworld.page.link/ya783ixb3MuMNcr47...
Gbr330
23.06.2021 09:07
Этапы, которых стоит придерживаться при разработке любых баз данных: НЕСКОЛЬКО ОТВЕТОВ Создание презентаций и связей с ними. Разработка и создание отчетов для вывода данных на печать...
natabudnikova
23.06.2021 08:33
Массива и увеличьте на 5 значения всех элементов массива, кроме первого и последнего. решите на паскале...
Demix485
02.12.2021 10:56
Дано два списки: [ Мова , Pascal ] і [« - це мова , процедурного програмування ]. Об’єднайте списки в один і перетворіть його на рядок. python...
kitsrarr
09.10.2019 11:02
Составьте программу, которая имитирует работу калькулятора. работе делается в visual studio....
Nastena11102003
09.10.2019 11:01
Какое значение не может быть использовано в операторе выбора?...
xkhs1sjsiXjjs
09.10.2019 10:56
Информатика перевод из одной системы счисления в другую ...
саша4246
09.10.2019 10:52
На числовой оси даны три точки а б с правила ли что точки б и с лежат по разные стороны от а. написать на языке c++...
aaa140
20.06.2019 12:20
Кого из героев сказок напоминает персей?...
Популярные вопросы
графиктері өзара параллель болатын функцияларды тауып,жауабын сәйкес еріңдер...
2
Решите задачи. 1. Зависимость скорости от времени имеет вид: V= 80 – 5t. Определите:...
3
Назовите и запишите в тетрадь, какие элементы Вы видите на рис.1, 2 О - О - СD -...
2
Операционная стстема это word/windows/basic...
2
Основной регион распространения кочевого скотоводства: Северный КазахстанВосточный...
3
I always my teacher in class.3) listenes to2) listens to3) listen to...
2
Как складывались торговые пути во время династии Тан...
1
4 .предотвращающая дальнейшее падение народного хозяйства необходимо перестроить...
2
Найдите сумму бесконечно убывающей прогрессии 10, 1 , 1/10...
3
Что верно о свойствах Газа А. газы сохраняет объемб. газы сохраняют формув. сохранение...
3
a: array[1..100] of integer;
i, n: integer;
begin
{ввод массива}
n := 15;
writeln('Данные массива:');
for i := 1 to n do
begin
a[i] := random(40 + 40) - 40;
write(a[i], ' ');
end;
writeln();
{изменение элементов}
for i := 1 to n do
begin
if a[i] mod 5 = 0 then
a[i] := 2 * a[i]
else a[i] := a[i] - 2;
write(a[i], ' ');
end;
end.