Составьте программу для вычисления суммы цифр заданного трехзначного числа. на паскале

kseniawkk kseniawkk    1   16.09.2019 22:40    1

Ответы
пупсик145 пупсик145  10.08.2020 21:29
Var
  n:integer;
 
begin
  Write('n = '); Read(n);
  Writeln(n div 100+(n div 10) mod 10+n mod 10)
end.

Пояснения.
n div 100 дает первую цифру: результат деления нацело числа на 100.
(n div 10) mod 10 дает вторую цифру: вычисляется результат деления нацело числа на 10 и от него берется остаток деления на 10.
n mod 10 дает третью цифру: остаток целочисленного деления числа на 10.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика