Составьте программу для решения следующей . дано четырехзначное число. определить делится ли это число на все свои цифры.

Сергій098765 Сергій098765    3   25.06.2019 07:30    2

Ответы
lana231075 lana231075  20.07.2020 15:18
Program zadacha;
var a,b,c,d,e: integer;
begin
writeln ('Введите четырехзначное число');
readln (a);
b:=a div 1000;
c:=a div 100;
c:=c mod 10;
d:=a mod 100;
d:=d div 10;
e:=a mod 10;
if (a mod b = 0) and (a mod c = 0) and (a mod d = 0) and (a mod e = 0) then writeln ('Число делится на все свои цифры')
else writeln ('Число не делится на все свои цифры');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика