tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу для решения
Составьте программу для решения одной из следующих , которая запрашивает значение элементов одномерного числового массива а и подсчета суммы элементов массива, меньших своего номера.
лиза12322
2 30.07.2019 12:50
1
Ответы
Alma88
03.10.2020 17:29
//Pascal ABC.NET v3.1 сборка 1219
Const
n=5;
Var
a:array[1..n] of integer;
i,s:integer;
begin
for i:=1 to n do
begin
readln(a[i]);
if a[i]<i then s:=s+a[i];
end;
writeln(s);
end.
Пример ввода:
2
2
1
1
2
Пример вывода:
4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Artem3460
16.05.2021 22:14
Имволы, которые можно использовать для записи программы: 6 G Ю ж z...
081105gr
16.05.2021 22:18
нужно найти конечное значение s а) s:=0; n:=10; For i:=2 To n Do s:=s+100 div i; б) s:=0; for i:=-5 to 0 do n:=i*i; s:=s+n; в) n:=5; s:=0; for i:=1 to n do s:=i; writeln(s);...
armine8
16.05.2021 22:19
Написать программу на языке Python Задание к работе решить систему нелинейных уравнений вида (см картинку) графическим...
kristinka078
07.08.2019 19:40
Некоторый алфавит состоит из 64 различных символов какой информационный объем в байтах фразы давайте жить дружно...
timekid
07.08.2019 19:40
Сообщение занимает 15 страниц и содержит 175,8 килобайт информации. сколько строк на странице,если симаолов в каждой строке 25 и использована кадировка ascii?...
2Velial1
30.05.2020 19:47
Выполнить сложение пар чисел в модифицированном дополнительном и модифицированном обратном кодах. Полученные результаты перевести в прямой код и сравнить. A1=+110101 A2=-000001...
motay121
30.05.2020 19:28
Встановіть відповідність між властивостями багаторядкового поля Memo в середовищі програмування Lazarus. 1. Lines 2. Lines.Count 3. ScrollBar 4. ReadOnly а) Наявність чи...
PoLyyKo
30.05.2020 19:28
Excel Желательно файлом, 2 задание через формулыЗаранее Или скажите как решать, буду благодарен...
mama1488
30.05.2020 19:20
От ) Паскаль В центре графического окна рисовать окружности с радиусом, заданным датчиком случайных чисел со скоростью 250 мсек. Цвет окружностей и их радиус выбрать случайным...
maxzaytsev5120
07.09.2019 23:10
украшение дома друзья его посещающие чему равен информационный объем в битах....
Популярные вопросы
1)плюсы в появлении новых мест для строительства жилья. 3 плюса. 2)минусы...
3
Как зависит характер течения от рельефа озеро виктория...
3
Аня купила проездной билет на месяц и сделала 39 поездок. ли она, если...
1
Три партії зовні однакових деталей. у першій партії 20 стандартних і...
3
Определите характер произведения приключения чиполлино . объясните, как...
1
Ключевский писал нет ничего враждебные культуре чем цивилизация напишите...
2
When jane was a little girl, she (prefers/ preferred) tea to coffee....
2
Из орфографического словоря выписать 10 слов где часто нарушатся орфографическая...
1
4. посмотри, как образовано слово «подарочками»: поплыть, дарят, козочка,...
1
Стороны треугольника равны 17 см, 21 см, 10 см. вычисли наибольшую высоту...
2
Const
n=5;
Var
a:array[1..n] of integer;
i,s:integer;
begin
for i:=1 to n do
begin
readln(a[i]);
if a[i]<i then s:=s+a[i];
end;
writeln(s);
end.
Пример ввода:
2
2
1
1
2
Пример вывода:
4