Составьте программу для решения двух квадратных уравнений используя процедуру решения квадратного уравнения​

nataliakonstan1 nataliakonstan1    2   05.04.2019 07:08    1

Ответы
nomar nomar  28.05.2020 17:03

Var a,b,c,d,x1,x2: real;

Begin

Clrscr;

Write('введите коэффициенты уравнения a,b,c'); readln(a,b,c);

D:=b*b-4*a*c;

If d>=0 then

Begin

X1:=(-b+sqrt(d))/(2*a); x2:=(-b-sqrt(d))/(2*a);

Writeln('x1=',x1' x2=',x2)

END;

Else writeln('действительных корней нет')

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика