Составьте программу дискриминанта так, чтобы а,b,с -задавались генератором случайных чисел (random); +эта программа должна включать в себя массив ( в писать по возможности с объяснением)

твоёсолнце7 твоёсолнце7    2   18.05.2019 08:20    3

Ответы
СветаТихая СветаТихая  11.06.2020 14:37

Var koef:array[1..3] as integer; 

d:real;

i:integer;

Begin

Randomize;

;Генерируем коэффициенты a b c

for i:=1 to 3  do

begin

koef[i]:=random(100);

end;

;Считаем дискриминант 

d:=koef[2]*koef[2]-4*koef[1]*koef[3];

;выводим ответ

Writeln(d:5:2);

end.

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика