tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить програму которая
Составить програму которая находит в одномерном массиве мах значение всего n элементов в массиве
Ksenia2004bi
1 30.07.2019 20:30
0
Ответы
Куку1560
28.09.2020 08:18
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Writeln('Max=',a.Max)
end.
Тестовое решение
n= 15
5 31 -24 31 -72 49 -19 -42 86 73 92 -11 -4 -81 -85
Max=92
ПОКАЗАТЬ ОТВЕТЫ
Катядонецк
28.09.2020 08:18
Var
i, n: integer;
a: array[1..100] of integer;
begin
write('n = '); readln(n);
for i := 1 to n do
begin
a[i] := random(100) - 50;
write(a[i], ' ');
if (i=1) or (max<a[i]) then
max:=a[i];
end;
writeln();
writeln('Max: ', max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Аропахора
28.08.2019 22:00
Вэлектронной таблице значение формулы =сумм(в3: е3) равно 20. чему равно значение формулы =срзнач (в3: f3), если значение ячейки f3 равно 5?...
olya12011
17.04.2019 07:37
Синформатикой завод, стоящий на берегу реки, сбрасывает в нее ежедневно случайным образом (из-за неисправности очистных сооружений) от 0 до 30 кг вредных веществ. за каждый килограмм...
hakimjon232
17.04.2019 07:24
На тесте по информатике было , дословно не помню, но суть такая: запишите условие удовлетворяющие помеченным элементам массива. и дан двумерный массив n*n. предположим что помечены...
themaximka41
17.04.2019 09:14
3. текст программы с ошибкой представлен ниже: program n1; var a: array [1..8] of integer; s, k: integer; beginfor k : = 1 to 8 do readln (a[k]); s : = 0; for k : =1 to 8 doif...
отличник732
17.04.2019 09:13
Дано двузначное число получить новое числа с перестановкой цифр заданного сделайте с c++...
Ондруй
30.10.2020 10:27
четверть почти закончился до 12:30...
sashak73
30.10.2020 10:27
Составь слово из букв с т р и п к ...
thanksagainand
30.10.2020 10:27
Коллаж-листовку на тему «Правила защиты от кибер угроз». ...
dominikakrestina
30.10.2020 10:27
В одной из кодировок Unicode каждый символ кодируется двумя байтами. Коля написал текст (в нём нет лишних пробелов): «Як, лис, барс, жираф, гепард, медведь, росомаха — дикие животные»....
veraeliseeva718
24.08.2020 20:14
Розв язати рівняння 1/7x-2=0 і -0,2x=4 та записати добуток їх коренів...
Популярные вопросы
Какое местоимние превращается в союз если его прочитать с права на лево?...
1
Сказали выучить 3 пословицы про смелость на казахском языке...
2
Как определить род прилогательного,...
3
Look at the list. ask and answer about asels list...
1
Какие слова образованны с приставки, а какие с приставки и суффикса? : прирост,подросток,приморье,побратимы,независимость,забайкалье,антициклон,подоконник...
2
42 секунды и четыре пятых минуты сравнить...
2
Измени одну букву в словах,подбери и назови к каждому слову проверочные.запиши...
2
Сделать .fill in the correct particle or preposition in the following sentences....
1
3/4 килограмма и 750 грамм сравнить...
2
Як решить улітку на базі відпочивало 800 дітей. у червні 250 дітей, а в липні...
3
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Writeln('Max=',a.Max)
end.
Тестовое решение
n= 15
5 31 -24 31 -72 49 -19 -42 86 73 92 -11 -4 -81 -85
Max=92
i, n: integer;
a: array[1..100] of integer;
begin
write('n = '); readln(n);
for i := 1 to n do
begin
a[i] := random(100) - 50;
write(a[i], ' ');
if (i=1) or (max<a[i]) then
max:=a[i];
end;
writeln();
writeln('Max: ', max);
end.