Составить программы pasсal 1) даны величины двух углов треугольника в градусах. составьте программу, которая определяет, существует ли такой треугольник. если да, то будет ли он остроугольным, прямоугольным или тупоугольным. 2)на плоскости xoy заданы своими координатами три не точки а(x1, y1), b(x2, y2) , и c(x3 , y3). составить программу, которая определяет, где расположена точка c ; выше, ниже или на отрезке ав.

AutWezer AutWezer    2   05.07.2019 07:00    0

Ответы
NaTaShA0930 NaTaShA0930  02.10.2020 20:30
Первая задача
program firstProgram
var ug1, ug2: real;
begin
write("Введите первый угол: ");
read(ug1);
write("Введите второй угол: ");
read(ug2);
if ((ug1 + ug2) < 180)
begin
if ((ug1 > 90) or (ug2 > 90)) write("Треугольник тупоугольный");
else if ((ug1 = 90) or (ug2 = 90)) write("Треугольник прямоугольный");
else write("Треугольник остроугольный");
end
end
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика