Составить программу заполнения одномерного массива, так чтобы его i-ый элемент был равен a[i]=i*i+10 паскаль

ханито ханито    2   13.09.2019 06:30    0

Ответы
Riek Riek  07.10.2020 11:16
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrGen(ReadInteger('n='),i->i*i+10); a.Println
end.

Пример
n= 13
10 11 14 19 26 35 46 59 74 91 110 131 154
ПОКАЗАТЬ ОТВЕТЫ
BitBul1 BitBul1  07.10.2020 11:16
Program zap;
var a:array [1..10000] of integer; i,n:integer;
begin 
Writeln('Введите количество элементов '); 
Readln(n); 
for i:=1 to N do 
  begin 
   a[i]:=i*i+10;
   Writeln(a[i]) 
  end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика