Составить программу, выводящую значение true или false. шахматный король за один ход может переместиться с одного заданного поля на другое (каждое после задано двумя координатами - целыми числами от 1 до 8). на паскале

tatiana158 tatiana158    3   27.09.2019 00:20    3

Ответы
fhdsjkfalhd fhdsjkfalhd  08.10.2020 21:28

Program KING;

Var x,y,x1,y1: integer;

Begin

writeln('Введите координаты расположения Короля:');

write('Коор. x - '); readln(x);

write('Коор. y - '); readln(y);

writeln('Введите координаты клетки хода:');

write('Коор. x - '); readln(x1);

write('Коор. y - '); readln(y1);

if ((x = x1) and (y = y1))

then writeln('FALSE')

else if (abs(x1 - x) < 2)

then if (abs(y1 - y) < 2)

then writeln('TRUE')

else writeln('FALSE')

else writeln('FALSE');

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика