Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10. (через паскаль)

верника3 верника3    1   12.03.2019 00:50    5

Ответы
oksana2000001 oksana2000001  24.05.2020 23:10

Паскаль.

 

 

program jjj;

var a: array [1..10] of integer; i,summa,proizv:integer;

begin

for i:=1 to 10 do begin

   Writeln('напишите элемент массива номер ',i); read(a[i]);

                        end;

For i:=1 to 10 do begin

                              if a[i] mod 2=0 then summa:=summa+a[i] else

                                if (a[i]<=10) and (a[i]>=1) then  proizv:=proizv*a[i];

                         end;

Writeln(summa,'   ',proizv); readln;

end.

 

Жирным - это то, что я добавил)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика