Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом h.


x∈[0,π]
h=π/8

Используя var, const, writeln и т.д.


f= \frac{sinx+cosx}{1+x^2}
Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шаго

ledilove77 ledilove77    2   30.05.2020 20:41    1

Ответы
H3RURG H3RURG  06.08.2020 20:24
begin var f: real -> real := x -> (sin(x)+cos(x))/(1+sqr(x)); PartitionPoints(0, Pi, 8).Tabulate(x -> f(x)) .ForEach(x->writeln('x:',x.Item1:7:3,'    y:',x.Item2:7:3)); end.

или без косметики:

begin PartitionPoints(0,Pi,8).Tabulate(x->(sin(x)+cos(x))/(1+sqr(x))).Print end.

Примеры работ:


Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом
Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика