составить программу. Вводятся 2 числа a и b. Где а- натуральное число, b-число от 1 до 9. С цикла найти сколько раз число b встречается внутри числа а.

Пример:

а=3464 b=4

Результат 2 (раза)

Через Паскаль.

Var
Begin Readln и тд

anzoroglyan1 anzoroglyan1    1   16.11.2020 14:44    0

Ответы
nurgi12345 nurgi12345  16.12.2020 14:46

program z1;

var a,b,k: integer;

begin

k:=0;

write ('a = ');

read(a);

write ('b = ');

read(b);

while a > 0 do

begin

if a mod 10 = b then k:=k+1;

a:=a div 10

end;

write('Результат ',k)

end.

Объяснение:

Вводим числа

Цикл с предусловием

Если последняя цифра числа а равна числу b, то значение k увеличиваем на 1

Изменяем значение а, на целый результат деления на 10

Вывод значения k

mod - остаток от целочисленного деления

div - целочисленное деление

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика