tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу возведения
Составить программу возведения натурального числа в квадрат, используя следующую закономерность: i2 =1 2 2=1+3 з2 =1 + 3 + 5 42=1+3+5+7 п2 = 1 + 3 + 5 + 7 + 9 + . . + 2 п - 1 программа pascal
Машуня55
2 17.07.2019 04:40
5
Ответы
Jordano23Mirra
25.08.2020 09:19
Всё до безобразия просто:
var n:integer; nn:real;
begin
write('Введи число: ');
readln(n);
for var i:=1 to n do nn:=nn+(2*i-1);
writeln(n,'^2=',nn);
end.
ПОКАЗАТЬ ОТВЕТЫ
allaxarchenko
25.08.2020 09:19
Function MySQR(n : Integer) : Integer;
Begin
If n>1 then MySQR:=n+MySQR(n-2) else MySQR:=1;
end;
Var a : Integer;
Begin
Readln(a);
Writeln(MySQR(a*2-1));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
София1991
12.05.2021 19:56
НАЙДИТЕ ФОРМУЛУ С ОШИБКОЙ, ЗАПИСАННУЮ В ЯЧЕЙКЕ ТАБЛИЦЫ MICROSOFT EXCEL: a.(2/3) b.А2 c.В+А3 d.3 e.2 f.А1/5...
Arianadrem
19.09.2019 09:50
Какое число будет выведено на экран в результате выполнения фрагмента программы? t: =1; i: =0; repeat i: =i+1; t: =t*4; until t 1000; write (i);...
anytka1312
01.03.2020 18:52
Скласти блок схему до алгоритму виконання при виборі сніданку...
Masha45322
01.03.2020 18:53
1. Напишите программу, которая вводит из файла весовую матрицу графа и определяет длины всех оптимальных маршрутов с алгоритма Флойда-Уоршелла.Оцените асимптотическую сложность...
SmilLl
09.02.2021 20:13
Назовём данную таблицу TEMPERATURA. Месяц 1 2 3 4 5 6 7 8 9 10 11 12 Температура −25 −15 −9 2 6 12 24 25 15 5 −4 −11 Тогда TEMPERATURA [6]=...
максир
22.04.2021 21:58
До іть написати задачу в Python будь-ласка.Велике дякую) Напишіть програму, щоб конвертувати усі введені користувачем одиниці часу (дні, години, хвилини, секунди) в загальну...
kono100216
22.04.2021 21:58
В питоне. совершенно не понимаю что и куда...
KawaiLOL
22.04.2021 22:00
Сделайте эти два номера вас...
Ismira1805
22.04.2021 22:02
Необходимо записать это в pitone....
nastyakotika
22.04.2021 22:03
Я в поверпоинте ноль просто. ...
Популярные вопросы
1) что такое зимницы? в каких местах они возникали и почему? 2) какие...
1
Не с разными частями речи запишите примеры, объяснив написание. (не)...
3
:девочка должна купить шарики на 80 рублей,а один шарик стоил 3 рубля.сколько...
3
Составь схему. из двух посёлков, расстояние между которыми 30 км, одновременно...
1
Вопрос сложный могут ли у кареглазых родителей родится голубого глазый...
3
Вкаких словах есть все непарные звонкие согласные звуки. музей санаторий...
3
На слову говорить нада найти антоним...
2
Надо склонять (падежи) слово (во множественном числе)...
1
Собака гонится за лисицей со скоростью 750 м/мин ,а лисица убегает от...
3
Вырази в метрах,дециметрах и сантиметров: 857 см.,2065см.,9906см.,8000см...
3
var n:integer; nn:real;
begin
write('Введи число: ');
readln(n);
for var i:=1 to n do nn:=nn+(2*i-1);
writeln(n,'^2=',nn);
end.
Begin
If n>1 then MySQR:=n+MySQR(n-2) else MySQR:=1;
end;
Var a : Integer;
Begin
Readln(a);
Writeln(MySQR(a*2-1));
end.