Составить программу в паскале.расчет значения функции x-2/sqrt(x*x-2*x) при х из отрезка (-10; 10) изменяющимся с шагом 1.должен быть цикл for.заранее

Gir9 Gir9    3   25.09.2019 03:20    0

Ответы
13Улька11 13Улька11  21.08.2020 15:19
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  for var x:=-10 to 10 do
    Writeln(x:3,x-2/Sqrt(x*x-2*x):15:10)
end.

Как видно из представленных во вложении результатов, современный Паскаль легко справляется и с отрицательным значением подкоренного выражения (NaN - Not a Number - не число) и с делением на ноль (-infinity - минус бесконечность).

Составить программу в паскале.расчет значения функции x-2/sqrt(x*x-2*x) при х из отрезка (-10; 10) и
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика