Составить программу в паскале массив a(m,n) заполнить случайными числами из промежутка [-15; -8] и подсчитать произведение элементов чётных строк.исходный массив и результат вывести на экран
Вместо 20 можно подставить любое число, 20 соответствует M,N
program new; var a:array [1..20,1..20] of integer; i,j,sum:integer; begin randomize; for i=1 to 20 do begin for j=1 to 20 do begin a[i,j]:=random(8)-15 end; end; for i=2 to 20 do begin for j=1 to 20 do begin sum:=sum+a[i,j]; i:=i+2; end; end; for i=1 to 20 do begin for j=1 to 20 do begin write(a[i,j]); end; writeln; end; writeln('Сумма равна ',sum:8); end.
P.S. Делал без паскаля если какие то ошибки то пиши
program new;
var a:array [1..20,1..20] of integer; i,j,sum:integer;
begin
randomize;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
a[i,j]:=random(8)-15
end;
end;
for i=2 to 20 do
begin
for j=1 to 20 do
begin
sum:=sum+a[i,j];
i:=i+2;
end;
end;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
write(a[i,j]);
end;
writeln;
end;
writeln('Сумма равна ',sum:8);
end.
P.S.
Делал без паскаля если какие то ошибки то пиши