Составить программу, удваивающую буквы “а” и “б” в слове. pascal

zaharuch zaharuch    3   30.09.2019 20:01    1

Ответы
madama1994 madama1994  09.10.2020 06:13
PascalABC.NET 3.4.2, сборка 1843 от 24.10.2018Внимание! Если программа не работает, обновите версию!

begin

 ReadlnString.Select(t -> LowCase(t) in ['а', 'б'] ? 2 * t : t)

     .JoinIntoString('').Println

end.


А роза упала на лапу АзораАА розаа упаалаа наа лаапу ААзораа
ПОКАЗАТЬ ОТВЕТЫ
Killer9568 Killer9568  09.10.2020 06:13

var s:string;

i:integer;

begin

write ('Введите строку: ');

readln(s);  

for i:=length(s) downto 1 do

begin

if s[i]='а' then insert('а',s,i);

if s[i]='б' then insert('б',s,i);

if s[i]='А' then insert('А',s,i);

if s[i]='Б' then insert('Б',s,i);

end;

writeln(s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика